
<!DOCTYPE html>

<html lang="en-US" prefix="og: http://ogp.me/ns#">

	<head>
		<!-- Website Meta -->
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="google-site-verification" content="BTQaC_o1rPhVeHCjRae6HybA0ZWTw1ZyVQMaFkHvHDg" />

		<title>
			The DevOps Glossary | Caylent		</title>

		<!-- Icons -->
		<link rel="shortcut icon" href="https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/caylent/img/favicon.ico">
		<script src="https://cdn.optimizely.com/js/9831410611.js"></script>

		
<!-- This site is optimized with the Yoast SEO Premium plugin v5.6 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://caylent.com/devops-glossary/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The DevOps Glossary | Caylent" />
<meta property="og:description" content="Whether you’re new to the world of DevOps or a seasoned guru looking to brush up on pesky terminology, look no further. This glossary covers some of the core definitions you and your team need to know. So, without further delay: The DevOps Glossary Agent A small program designed to run on multiple machines, usually &hellip;" />
<meta property="og:url" content="https://caylent.com/devops-glossary/" />
<meta property="og:site_name" content="Caylent" />
<meta property="article:publisher" content="https://facebook.com/caylent" />
<meta property="article:tag" content="DevOps" />
<meta property="article:tag" content="Glossary" />
<meta property="article:tag" content="Terminology" />
<meta property="article:section" content="DevOps" />
<meta property="article:published_time" content="2017-12-21T08:00:45-08:00" />
<meta property="article:modified_time" content="2017-12-21T16:10:10-08:00" />
<meta property="og:updated_time" content="2017-12-21T16:10:10-08:00" />
<meta property="og:image" content="https://caylent.com/wp-content/uploads/2017/12/DevOps-Glossaryjpg-e1513901327937.jpg" />
<meta property="og:image:secure_url" content="https://caylent.com/wp-content/uploads/2017/12/DevOps-Glossaryjpg-e1513901327937.jpg" />
<meta property="og:image:width" content="512" />
<meta property="og:image:height" content="384" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Whether you’re new to the world of DevOps or a seasoned guru looking to brush up on pesky terminology, look no further. This glossary covers some of the core definitions you and your team need to know. So, without further delay: The DevOps Glossary Agent A small program designed to run on multiple machines, usually [&hellip;]" />
<meta name="twitter:title" content="The DevOps Glossary | Caylent" />
<meta name="twitter:site" content="@caylentinc" />
<meta name="twitter:image" content="https://i2.wp.com/caylent.com/wp-content/uploads/2017/12/DevOps-Glossaryjpg-e1513901327937.jpg?fit=512%2C384&#038;ssl=1" />
<meta name="twitter:creator" content="@caylentinc" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/caylent.com\/","name":"Caylent","potentialAction":{"@type":"SearchAction","target":"https:\/\/caylent.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/caylent.com\/devops-glossary\/","sameAs":["https:\/\/facebook.com\/caylent","https:\/\/www.instagram.com\/caylentinc\/","https:\/\/www.linkedin.com\/company\/6585178\/","https:\/\/www.youtube.com\/channel\/UCETlgM1aiLIKJ6AOgWfpdxA","https:\/\/twitter.com\/caylentinc"],"@id":"#organization","name":"Caylent","logo":"http:\/\/caylent.com\/wp-content\/uploads\/2017\/09\/caylent.png"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//a.optnmstr.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Caylent &raquo; Feed" href="https://caylent.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Caylent &raquo; Comments Feed" href="https://caylent.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Caylent &raquo; The DevOps Glossary Comments Feed" href="https://caylent.com/devops-glossary/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/caylent.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='grid-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/css/grid.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='animate-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/css/animate.min.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='fonts-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/css/fonts.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/style.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='afs-fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='afs-styles-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/ajax-filter-search/core/css/style.min.css?ver=4.9.1' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.4' type='text/css' media='all' />
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/js/app.js?ver=4.9.1'></script>
<script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='//a.optnmstr.com/app/js/api.min.js?ver=1.3.2'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<script type="text/javascript">
	!function(){var analytics=window.analytics=window.analytics||[];if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.0";
		window.analytics.load("gnlmMn2ZZrI4GeAcIwsrM2Ypct9YwygS");
	window.analytics.page();
	  }}();
</script>
<link rel='https://api.w.org/' href='https://caylent.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://caylent.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://caylent.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/p9gBeo-Bd' />
<link rel="alternate" type="application/json+oembed" href="https://caylent.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcaylent.com%2Fdevops-glossary%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://caylent.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcaylent.com%2Fdevops-glossary%2F&#038;format=xml" />
<script type="text/javascript">
			   var ajaxurl = "https://caylent.com/wp-admin/admin-ajax.php";
			   var scriptpath = "https://caylent.com";
			 </script>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<meta name="viewport" content="width=device-width, initial-scale=1.0, minimal-ui">
				<!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
				<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<meta name="description" content="Whether you’re new to the world of DevOps or a seasoned guru looking to brush up on pesky terminology, look no further. This glossary covers some of the core definitions you and your team need to know. So, without further delay: The DevOps Glossary Agent A small program designed to run on multiple machines, usually&hellip;" />
	</head>

	<body class="post-template-default single single-post postid-2307 single-format-standard post-devops-glossary">
    <header id="header" class="header">
			<div class="container">
				<div class="row">
					<div class="grid-full">
						<a href="https://caylent.com"><h1 class="logo">Caylent</h1></a>

						<!-- <nav id="header-nav" role="navigation"><div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-2105" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2105"><a href="https://caylent.com/about/">About</a></li>
<li id="menu-item-2290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2290"><a href="https://caylent.com/pricing/">Pricing</a></li>
<li id="menu-item-1981" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1981"><a href="https://help.caylent.com/hc/en-us">Support</a></li>
<li id="menu-item-1980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1980"><a href="https://docs.caylent.com/">Docs</a></li>
<li id="menu-item-1982" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-1982"><a href="https://caylent.com/blog/">Blog</a></li>
<li id="menu-item-2304" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2304"><a href="https://caylent.com/category/resources/">Resources</a></li>
<li id="menu-item-1983" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1983"><a href="https://app.caylent.com/login">Log in</a></li>
<li id="menu-item-2291" class="btn menu-item menu-item-type-post_type menu-item-object-page menu-item-2291"><a href="https://caylent.com/sign-up/">Sign up</a></li>
</ul></div></nav> -->

						<nav id="site-navigation" class="main-navigation" role="navigation">
            <button class="menu-toggle">Menu</button>
            <div class="menu-header-container"><ul id="menu-header-1" class="nav-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2105"><a href="https://caylent.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2290"><a href="https://caylent.com/pricing/">Pricing</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1981"><a href="https://help.caylent.com/hc/en-us">Support</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1980"><a href="https://docs.caylent.com/">Docs</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-1982"><a href="https://caylent.com/blog/">Blog</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2304"><a href="https://caylent.com/category/resources/">Resources</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1983"><a href="https://app.caylent.com/login">Log in</a></li>
<li class="btn menu-item menu-item-type-post_type menu-item-object-page menu-item-2291"><a href="https://caylent.com/sign-up/">Sign up</a></li>
</ul></div></nav>
					</div><!-- .grid-full -->
				</div><!-- .row -->
			</div><!-- .container -->
		</header><!-- .header -->

	<section class="container">
		<div class="row">
			<div class="grid-full">

				<!-- Open the loop -->
				
					<article class="post-2307 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-resources tag-devops tag-glossary tag-terminology" id="post-2307">
						<header>
							<div class="meta"><time datetime="2017-12-23T19:57:58+00:00" pubdate>December 21st, 2017</time></div>

							<h1 id="post-2307" class="entry_title">The DevOps Glossary</h1>

							<div class="author">
								<img alt='' src='https://secure.gravatar.com/avatar/f16cb61bf012d7b8d0c0c8f0d4764ffa?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f16cb61bf012d7b8d0c0c8f0d4764ffa?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <em>Written by Caylent Team</em>
							</div><!-- .author -->

							<img width="1024" height="768" src="https://i2.wp.com/caylent.com/wp-content/uploads/2017/12/DevOps-Glossaryjpg-e1513901327937.jpg?fit=1024%2C768&amp;ssl=1" class="attachment-large size-large wp-post-image" alt="DevOps Glossary" data-attachment-id="2309" data-permalink="https://caylent.com/devops-glossary/devops-glossaryjpg/" data-orig-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/12/DevOps-Glossaryjpg-e1513901327937.jpg?fit=512%2C384&amp;ssl=1" data-orig-size="512,384" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="DevOps Glossary" data-image-description="" data-medium-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/12/DevOps-Glossaryjpg-e1513901327937.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/12/DevOps-Glossaryjpg-e1513901327937.jpg?fit=1024%2C768&amp;ssl=1" />						</header>

						<div class="entry">

							<p>Whether you’re new to the world of DevOps or a seasoned guru looking to brush up on pesky terminology, look no further. This glossary covers some of the core definitions you and your team need to know.</p>
<p>So, without further delay:</p>
<h1>The DevOps Glossary</h1>
<h2>Agent</h2>
<p>A small program designed to run on multiple machines, usually to control or report the status of them.</p>
<h2>Agile</h2>
<p>A method of developing software whereby teams continuously evaluate their performance and adjust processes to become more efficient.</p>
<h2>Amd64</h2>
<p>An instruction set for a CPU that uses 64bits to address memory.</p>
<h2>AUFS</h2>
<p>Advanced multi-layered unification file system. This is a union-capable file system used to merge multiple directories into a single directory.</p>
<h2>Azure Container Registry</h2>
<p>A container repository from Microsoft. Allows developers to store and manage media assets for container deployments.</p>
<h2>Btrfs</h2>
<p>A copy-on-write (COW) file system that uses B-trees to organize information on-disk.</p>
<h2>Cluster</h2>
<p>A group of computers that are all running the same program. Usually, a cluster is housed within the same data center.</p>
<h2>Configuration Management</h2>
<p>A program that manages values that are applied to code running in an environment. These values can be applied in a variety of ways to reduce the time it takes to deploy code or make deployment changes.</p>
<h2>Container Registry</h2>
<p>A service that hosts containers to store, manage, and deploy images. These services may also host multiple versions of the same container.</p>
<h2>Container Repository</h2>
<p>A collection of related images that may have the same name and different tags. Repositories usually provide a different version of the same application or service.</p>
<h2>Containers</h2>
<p>A lightweight standalone process on a computer that has limited access to the underlying hardware. Some of the hardware may be emulated by software.</p>
<h2>Continuous Delivery</h2>
<p>A development practice in which code changes are automatically built, tested, and prepped for production. This is an automated way to deliver new features to customers with limited or no human action.</p>
<h2>Continuous Integration</h2>
<p>A development practice in which, when new features are created, they are automatically tested in an environment that closely mimics production to ensure they are working properly with existing code.</p>
<h2>Deployment</h2>
<p>The process of adding or updating code or configuration in an environment.</p>
<h2>DevOps</h2>
<p>“The emerging professional movement that advocates a collaborative working relationship between Development and IT Operations, resulting in the fast flow of planned work (i.e., high deploy rates), while simultaneously increasing the reliability, stability, resilience and security of the production environment.” &#8211; <a href="http://www.thinkhdi.com/~/media/HDICorp/Files/White-Papers/whtppr-1112-DevOps-kim.pdf" target="_blank" rel="noopener">Gene Kim</a></p>
<h2>Docker</h2>
<p>A popular open platform for developers and sysadmins. This software provides tools for creating and maintaining containers.</p>
<h2>Horizontal Scaling</h2>
<p>Adding more computers to a problem to speed up execution or increase reliability.</p>
<h2>Iterations</h2>
<p>Repeated cycles used to develop a system. Modifications or the addition of new capabilities designed to enhance the system usually take place at the start of each iteration.</p>
<h2>Kanban</h2>
<p>A method of organizing work so what is being worked on, or items that have issues, is clearly indicated to the entire team.</p>
<h2>Kubernetes</h2>
<p>An open-source system used to automate containerized application deployment, scaling, and management.</p>
<h2>Legacy Application</h2>
<p>A program that has reached its end of life and has no new features being added. Usually, a legacy application is in the process of being replaced by newly created software.</p>
<h2>Microservice</h2>
<p>A stateless program that performs a limited set of features that can be horizontally scaled.</p>
<h2>Monolith</h2>
<p>An application that contains all the behavior of the application in a single program. There may be single or multiple instances of this application running, but they all run the same code.</p>
<h2>OverlayFS</h2>
<p>An example of a union capable files system used by docker to create the file system for containers. The successor to AUFS. Other popular file systems used in container environments include Gluster, NFS, Ceph, etc.</p>
<h2>Penetration Testing (Pen Test)</h2>
<p>Security testing that evaluates an enterprises processes that may allow attackers unauthorized access to resources or information. This can also include physical access, social engineering or exploiting software.</p>
<h2>Recovery Point Objective (RPO)</h2>
<p>The amount of time that may pass during an outage incident before the amount of data loss exceeds the maximum allowable threshold. Usually detailed in a Business Continuity Plan.</p>
<h2>Recovery Time Objective (RTO)</h2>
<p>The amount of time within which a service and its business process must be restored in the event of an outage incident. Usually detailed in a Business Continuity Plan.</p>
<h2>Scrum</h2>
<p>A method of organizing work so that what is being created is constantly being evaluated. In this manner, problems are identified quickly and the most important features are being worked on first.</p>
<h2>Secret Management</h2>
<p>Software that allows code to access keys or certificates used to provide encryption.</p>
<h2>Service Oriented Architecture (SOA)</h2>
<p>An architecture pattern where features are broken up into different services that communicate over a network.</p>
<h2>Smoke/Integration Testing</h2>
<p>Tests that exercise an application in a realistic environment. These typically test the program’s behavior without inspecting its internal values. Instead, the program is tested by monitoring its outputs.</p>
<h2>Sprint</h2>
<p>A fixed time period where a planned amount of work is set to be completed. Sometimes a demo is done at the end to illustrate the work achieved.</p>
<h2>Stateful Program</h2>
<p>A program that tracks and stores information internally. These programs usually maintain the state of interaction by assigning values in designated storage fields.</p>
<h2>Stateless Program</h2>
<p>A program that does not maintain or store any information internally. By not storing any state these programs have the property that for any given input the output will always be the same. Many web services are stateless, while databases are not.</p>
<h2>Union-Capable File System</h2>
<p>A category of file system that allows directories and files from two different sources to be overlayed. These sources may be read-only or allow for writing.</p>
<h2>UnionFS</h2>
<p>An example of a union-capable file system used in Linux, FreeBSD, and NetBSD. Implements a union mount for other file systems.</p>
<h2>Unit Testing</h2>
<p>Testing a small module of code in isolation to the rest of the program.</p>
<p><em>Interested in discovering what DevOps can do for your organization? Check out our CTO Stefan Thorpe&#8217;s synopsis of The DevOps Handbook. Begin reading the book in bite-size pieces, starting with <a href="https://caylent.com/devops-handbook-introduction-summary/" target="_blank" rel="noopener">The Introduction Summary</a>.</em></p>
<hr />
<h3><img data-attachment-id="2308" data-permalink="https://caylent.com/devops-glossary/bryanabsher/" data-orig-file="https://i1.wp.com/caylent.com/wp-content/uploads/2017/12/BryanAbsher.jpg?fit=1280%2C853&amp;ssl=1" data-orig-size="1280,853" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Contributor: Bryan Absher" data-image-description="" data-medium-file="https://i1.wp.com/caylent.com/wp-content/uploads/2017/12/BryanAbsher.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i1.wp.com/caylent.com/wp-content/uploads/2017/12/BryanAbsher.jpg?fit=1024%2C682&amp;ssl=1" class="wp-image-2308 alignleft" src="https://i1.wp.com/caylent.com/wp-content/uploads/2017/12/BryanAbsher.jpg?resize=300%2C200&#038;ssl=1" alt="Contributor: Bryan Absher" data-recalc-dims="1" /></h3>
<h3><strong>Writer: <em>Bryan Absher</em></strong></h3>
<p>Bryan Absher is a Software Engineer who is passionate about new and old technology. He is currently working on large scale distributed applications and single page web apps in the Pacific Northwest.</p>
<p>Fun fact: Bryan has a cat and will dance your pants off.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-2307" class="share-twitter sd-button share-icon no-text" href="https://caylent.com/devops-glossary/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-2307" class="share-facebook sd-button share-icon no-text" href="https://caylent.com/devops-glossary/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://caylent.com/devops-glossary/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-2307" class="share-linkedin sd-button share-icon no-text" href="https://caylent.com/devops-glossary/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-136943392-2307-5a3eb54615856' data-src='https://widgets.wp.com/likes/#blog_id=136943392&amp;post_id=2307&amp;origin=caylent.com&amp;obj_id=136943392-2307-5a3eb54615856' data-name='like-post-frame-136943392-2307-5a3eb54615856'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: No Name Required --><div id="om-pugkjzrm3ljvvkau9zuo-holder"></div><script>var pugkjzrm3ljvvkau9zuo,pugkjzrm3ljvvkau9zuo_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){pugkjzrm3ljvvkau9zuo_poll(function(){if(window['om_loaded']){if(!pugkjzrm3ljvvkau9zuo){pugkjzrm3ljvvkau9zuo=new OptinMonsterApp();return pugkjzrm3ljvvkau9zuo.init({"u":"38164.684181","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.optnmstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;pugkjzrm3ljvvkau9zuo=new OptinMonsterApp();pugkjzrm3ljvvkau9zuo.init({"u":"38164.684181","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster -->
						</div><!-- .entry -->
					</article><!-- .the_post -->

				<!-- Close the loop -->
				
			</div><!-- .grid-full -->
		</div><!-- .row -->
	</section><!-- .content -->

	<section class="container">
		<div class="row">
			<div class="grid-full">
				<h3 class="title">Related Posts<h3>
				
							<article class="excerpt article-thumbnail">
								<header>
									<a href="https://caylent.com/devops-handbook-part-2-defining-devops-teams/" class="post-thumbnail-container"><img width="1024" height="576" src="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=1024%2C576&amp;ssl=1" class="post-thumbnail wp-post-image" alt="The #DevOps Handbook Series" srcset="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?w=1280&amp;ssl=1 1280w, https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?resize=1024%2C576&amp;ssl=1 1024w" sizes="(max-width: 1024px) 100vw, 1024px" data-attachment-id="2054" data-permalink="https://caylent.com/devops-handbook-introduction-summary/devops-handbook-cover/" data-orig-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=1280%2C720&amp;ssl=1" data-orig-size="1280,720" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The DevOps Handbook" data-image-description="" data-medium-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=1024%2C576&amp;ssl=1" /></a>

									<h2 id="post-2201" class="entry_title"><a href="https://caylent.com/devops-handbook-part-2-defining-devops-teams/">DevOps Handbook Series Part 2: Defining DevOps Teams</a></h2>
								</header>

								<div class="entry">
									<div class="author">
										<img alt='' src='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />										<em>Written by Stefan Thorpe</em>
									</div><!-- .author -->
								</div><!-- .entry -->
							</article><!-- .excerpt -->

				
							<article class="excerpt article-thumbnail">
								<header>
									<a href="https://caylent.com/devops-handbook-part-2-devops-methodology/" class="post-thumbnail-container"><img width="1024" height="576" src="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=1024%2C576&amp;ssl=1" class="post-thumbnail wp-post-image" alt="The #DevOps Handbook Series" srcset="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?w=1280&amp;ssl=1 1280w, https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?resize=1024%2C576&amp;ssl=1 1024w" sizes="(max-width: 1024px) 100vw, 1024px" data-attachment-id="2054" data-permalink="https://caylent.com/devops-handbook-introduction-summary/devops-handbook-cover/" data-orig-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=1280%2C720&amp;ssl=1" data-orig-size="1280,720" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The DevOps Handbook" data-image-description="" data-medium-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=1024%2C576&amp;ssl=1" /></a>

									<h2 id="post-2138" class="entry_title"><a href="https://caylent.com/devops-handbook-part-2-devops-methodology/">DevOps Handbook Series Part 2: Begin The DevOps Methodology</a></h2>
								</header>

								<div class="entry">
									<div class="author">
										<img alt='' src='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />										<em>Written by Stefan Thorpe</em>
									</div><!-- .author -->
								</div><!-- .entry -->
							</article><!-- .excerpt -->

				
							<article class="excerpt article-thumbnail">
								<header>
									<a href="https://caylent.com/devops-handbook-part-1-the-three-ways-cont/" class="post-thumbnail-container"><img width="1024" height="576" src="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=1024%2C576&amp;ssl=1" class="post-thumbnail wp-post-image" alt="The #DevOps Handbook Series" srcset="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?w=1280&amp;ssl=1 1280w, https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?resize=1024%2C576&amp;ssl=1 1024w" sizes="(max-width: 1024px) 100vw, 1024px" data-attachment-id="2054" data-permalink="https://caylent.com/devops-handbook-introduction-summary/devops-handbook-cover/" data-orig-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=1280%2C720&amp;ssl=1" data-orig-size="1280,720" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The DevOps Handbook" data-image-description="" data-medium-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/caylent.com/wp-content/uploads/2017/10/devops-handbook-cover.png?fit=1024%2C576&amp;ssl=1" /></a>

									<h2 id="post-2110" class="entry_title"><a href="https://caylent.com/devops-handbook-part-1-the-three-ways-cont/">DevOps Handbook Series Part 1: The Three Ways Cont.</a></h2>
								</header>

								<div class="entry">
									<div class="author">
										<img alt='' src='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />										<em>Written by Stefan Thorpe</em>
									</div><!-- .author -->
								</div><!-- .entry -->
							</article><!-- .excerpt -->

				
			</div><!-- .grid-full -->
		</div><!-- .row -->
	</section><!-- .container -->

	<section class="callout">
		<div class="container">
			<div class="row">
				<div class="grid-full">
					<div class="heading">
						<h1 class="headline">The DevOps container management platform</h1>

						<ul class="cloud_providers">
							<li class="aws">Amazon AWS</li><!-- .aws -->
							<li class="azure">Microsoft Azure</li><!-- .azure -->
							<li class="google_cloud">Google Cloud</li><!-- .google_cloud -->
							<li class="digital_ocean">Digital Ocean</li><!-- .digital_ocean -->
						</ul><!-- .cloud_providers -->

						<h2 class="sub-headline">Unlimited users. Unlimited applications. Unlimited stacks. Easily manage Docker containers across any cloud.</h2>

						<a class="button primary" href="https://app.caylent.com/signup/">Get Started—Free!</a>
					</div><!-- .heading -->
				</div><!-- .grid-full -->
			</div><!-- .row -->
		</div><!-- .container -->
	</section><!-- .callout -->


			<div class="container center-align-text ">
  <div class="row">
    <div class="grid-full">
      <div class="social-media-icons">
              </div>
    </div><!-- .grid-full -->
  </div><!-- .row -->
</div><!-- .container -->
	
	<footer id="footer" class="footer">
		<div class="container">
			<div class="row">
				<div class="grid-full">
					<!--
					<div class="social"><a href="https://twitter.com/caylentinc">Twitter</a> <a href="https://slackin-caylent.now.sh/">Slack</a> <a href="https://github.com/caylent/">GitHub</a></div>
				 	-->

					<nav id="footer-nav" role="navigation"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-1986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1986"><a href="https://caylent.com/">Home</a></li>
<li id="menu-item-1987" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1987"><a href="https://docs.caylent.com/">Docs</a></li>
<li id="menu-item-1988" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1988"><a href="https://help.caylent.com/hc/en-us">Support</a></li>
<li id="menu-item-2103" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2103"><a href="https://caylent.com/about/">About</a></li>
<li id="menu-item-1985" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-1985"><a href="https://caylent.com/blog/">Blog</a></li>
<li id="menu-item-2107" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2107"><a href="https://app.caylent.com/login">Log In</a></li>
<li id="menu-item-2321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2321"><a href="https://caylent.com/sign-up/">Sign Up</a></li>
</ul></div></nav>

					<p class="copy">&copy; 2017 Caylent, Inc. <span>|</span> <a href="https://caylent.com/terms-of-service/">Terms of Service</a> <span>|</span> <a href="https://caylent.com/privacy-policy/">Privacy Policy</a></p><!-- .copy -->
				</div><!-- .grid-full -->
			</div><!-- .row -->
		</div><!-- .container -->
	</footer><!-- .footer -->

	<a href="#0" class="top">Top</a>

	 <script type="text/javascript">
  analytics.track("Viewed Post", {"title":"The DevOps Glossary","category":"DevOps, Resources","noninteraction":true}, {"library":"analytics-wordpress"});
    
</script>
<script data-cfasync="false">
  document.onreadystatechange = function () {
    if (document.readyState == "complete") {
      var logout_link = document.querySelectorAll('a[href*="wp-login.php?action=logout"]');
      if (logout_link) {
        for(var i=0; i < logout_link.length; i++) {
          logout_link[i].addEventListener( "click", function() {
            Intercom('shutdown');
          });
        }
      }
    }
  };
</script>
<script data-cfasync="false">
  window.intercomSettings = {"app_id":"lsweki3y"};
</script>
<script data-cfasync="false">(function(){var w=window;var ic=w.Intercom;if(typeof ic==="function"){ic('reattach_activator');ic('update',intercomSettings);}else{var d=document;var i=function(){i.c(arguments)};i.q=[];i.c=function(args){i.q.push(args)};w.Intercom=i;function l(){var s=d.createElement('script');s.type='text/javascript';s.async=true;s.src='https://widget.intercom.io/widget/lsweki3y';var x=d.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);}if(w.attachEvent){w.attachEvent('onload',l);}else{w.addEventListener('load',l,false);}}})()</script>	<div style="display:none">
	<div class="grofile-hash-map-f16cb61bf012d7b8d0c0c8f0d4764ffa">
	</div>
	<div class="grofile-hash-map-d41e69c17d24335e3f8af6e8b16a9f57">
	</div>
	</div>
<!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Lightup post CTA --><div id="om-r3nfnaerczkvychrquwy-holder"></div><script>var r3nfnaerczkvychrquwy,r3nfnaerczkvychrquwy_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){r3nfnaerczkvychrquwy_poll(function(){if(window['om_loaded']){if(!r3nfnaerczkvychrquwy){r3nfnaerczkvychrquwy=new OptinMonsterApp();return r3nfnaerczkvychrquwy.init({"u":"38164.685002","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.optnmstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;r3nfnaerczkvychrquwy=new OptinMonsterApp();r3nfnaerczkvychrquwy.init({"u":"38164.685002","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster -->
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/caylent.com\/devops-glossary\/":2307};
	</script>
		<script type="text/javascript">var pugkjzrm3ljvvkau9zuo_shortcode = true;var r3nfnaerczkvychrquwy_shortcode = true;</script>
		<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/caylent.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9.1'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201751'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/js/navigation.js?ver=4.9.1'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/ajax-filter-search/core/js/script.min.js?ver=4.9.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/caylent.com\/wp-admin\/admin-ajax.php","nonce":"69b9ad5051","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/caylent.com\/wp-login.php?redirect_to=https%3A%2F%2Fcaylent.com%2Fdevops-glossary%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/postmessage.js?ver=5.4'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=5.4'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=5.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.4'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=20170629#ver=20170629' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-201751.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.4',blog:'136943392',post:'2307',tz:'-8',srv:'caylent.com'} ]);
	_stq.push([ 'clickTrackerInit', '136943392', '2307' ]);
</script>
		<script type="text/javascript">var omapi_localized = { ajax: 'https://caylent.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '823feba7b9', slugs: {"pugkjzrm3ljvvkau9zuo":{"slug":"pugkjzrm3ljvvkau9zuo","mailpoet":false},"r3nfnaerczkvychrquwy":{"slug":"r3nfnaerczkvychrquwy","mailpoet":false}} };</script>
		
	</body>
</html>
