
<!DOCTYPE html>

<html lang="en-US" prefix="og: http://ogp.me/ns#">

	<head>
		<!-- Website Meta -->
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="google-site-verification" content="BTQaC_o1rPhVeHCjRae6HybA0ZWTw1ZyVQMaFkHvHDg" />

		<title>
			SRE vs. DevOps: Any Common Ground? | Caylent		</title>

		<!-- Icons -->
		<link rel="shortcut icon" href="https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/caylent/img/favicon.ico">
		<script src="https://cdn.optimizely.com/js/9831410611.js"></script>

		
<!-- This site is optimized with the Yoast SEO Premium plugin v5.6 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Should it be one or the other? Or do Site Reliability Engineering and DevOps share common ground?"/>
<link rel="canonical" href="https://caylent.com/sre-vs-devops/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="SRE vs. DevOps: Any Common Ground? | Caylent" />
<meta property="og:description" content="Should it be one or the other? Or do Site Reliability Engineering and DevOps share common ground?" />
<meta property="og:url" content="https://caylent.com/sre-vs-devops/" />
<meta property="og:site_name" content="Caylent" />
<meta property="article:publisher" content="https://facebook.com/caylent" />
<meta property="article:tag" content="DevOps" />
<meta property="article:tag" content="DevOps Engineer" />
<meta property="article:tag" content="Google" />
<meta property="article:tag" content="Site Reliability Engineer" />
<meta property="article:tag" content="Site Reliability Engineering" />
<meta property="article:tag" content="SRE" />
<meta property="article:section" content="DevOps" />
<meta property="article:published_time" content="2018-06-28T08:00:59-07:00" />
<meta property="article:modified_time" content="2018-06-26T22:21:22-07:00" />
<meta property="og:updated_time" content="2018-06-26T22:21:22-07:00" />
<meta property="og:image" content="https://caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png" />
<meta property="og:image:secure_url" content="https://caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png" />
<meta property="og:image:width" content="1197" />
<meta property="og:image:height" content="721" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Should it be one or the other? Or do Site Reliability Engineering and DevOps share common ground?" />
<meta name="twitter:title" content="SRE vs. DevOps: Any Common Ground? | Caylent" />
<meta name="twitter:site" content="@caylentinc" />
<meta name="twitter:image" content="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png?fit=1197%2C721&#038;ssl=1" />
<meta name="twitter:creator" content="@caylentinc" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/caylent.com\/","name":"Caylent","potentialAction":{"@type":"SearchAction","target":"https:\/\/caylent.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/caylent.com\/sre-vs-devops\/","sameAs":["https:\/\/facebook.com\/caylent","https:\/\/www.instagram.com\/caylentinc\/","https:\/\/www.linkedin.com\/company\/6585178\/","https:\/\/www.youtube.com\/channel\/UCETlgM1aiLIKJ6AOgWfpdxA","https:\/\/twitter.com\/caylentinc"],"@id":"#organization","name":"Caylent","logo":"http:\/\/caylent.com\/wp-content\/uploads\/2017\/09\/caylent.png"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//a.optnmstr.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Caylent &raquo; Feed" href="https://caylent.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Caylent &raquo; Comments Feed" href="https://caylent.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Caylent &raquo; SRE vs. DevOps: Any Common Ground? Comments Feed" href="https://caylent.com/sre-vs-devops/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/caylent.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='grid-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/css/grid.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='animate-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/css/animate.min.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='fonts-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/css/fonts.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/style.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='afs-fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='afs-styles-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/ajax-filter-search/core/css/style.min.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.4' type='text/css' media='all' />
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/js/app.js?ver=4.9.6'></script>
<script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='//a.optnmstr.com/app/js/api.min.js?ver=1.3.2'></script>
<script type="text/javascript">
	!function(){var analytics=window.analytics=window.analytics||[];if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.0";
		window.analytics.load("gnlmMn2ZZrI4GeAcIwsrM2Ypct9YwygS");
	window.analytics.page();
	  }}();
</script>
<link rel='https://api.w.org/' href='https://caylent.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://caylent.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://caylent.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/p9gBeo-I5' />
<link rel="alternate" type="application/json+oembed" href="https://caylent.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcaylent.com%2Fsre-vs-devops%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://caylent.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcaylent.com%2Fsre-vs-devops%2F&#038;format=xml" />
<script type="text/javascript">
			   var ajaxurl = "https://caylent.com/wp-admin/admin-ajax.php";
			   var scriptpath = "https://caylent.com";
			 </script>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<meta name="viewport" content="width=device-width, initial-scale=1.0, minimal-ui">
				<!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
				<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<meta name="description" content="Software engineers spend significant amounts of time seeking to streamline software development and production. This endeavor results in constant changes that can cause software and performance defects which continue to consume even more time and productivity. This imbalance has created the necessity for constant care and maintenance of the development pipeline. And teams turn to&hellip;" />
	</head>

	<body class="post-template-default single single-post postid-2733 single-format-standard post-sre-vs-devops">
		<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>
    <header id="header" class="header">
			<div class="container">
				<div class="row">
					<div class="grid-full">
						<a href="https://caylent.com"><h1 class="logo">Caylent</h1></a>

						<!-- <nav id="header-nav" role="navigation"><div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-2105" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2105"><a href="https://caylent.com/about/">About</a></li>
<li id="menu-item-2290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2290"><a href="https://caylent.com/pricing/">Pricing</a></li>
<li id="menu-item-1982" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-1982"><a href="https://caylent.com/blog/">Blog</a></li>
<li id="menu-item-2573" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2573"><a href="#">Solutions</a>
<ul class="sub-menu">
	<li id="menu-item-2554" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2554"><a href="https://caylent.com/devops-as-a-service/">DevOps as a Service</a></li>
	<li id="menu-item-2574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2574"><a href="https://caylent.com/container-management-software/">Container Software</a></li>
</ul>
</li>
<li id="menu-item-2552" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2552"><a href="#">More Tools</a>
<ul class="sub-menu">
	<li id="menu-item-2565" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2565"><a href="https://caylent.com/devops-maturity-assessment/">DevOps Assessment</a></li>
	<li id="menu-item-1981" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1981"><a href="http://help.caylent.com">Support</a></li>
	<li id="menu-item-1980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1980"><a href="https://docs.caylent.com/">Docs</a></li>
	<li id="menu-item-2304" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2304"><a href="https://caylent.com/category/resources/">Resources</a></li>
	<li id="menu-item-2555" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2555"><a href="https://caylent.com/app-store/">App Store</a></li>
</ul>
</li>
<li id="menu-item-1983" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1983"><a href="https://app.caylent.com/login">Log in</a></li>
<li id="menu-item-2291" class="btn menu-item menu-item-type-post_type menu-item-object-page menu-item-2291"><a href="https://caylent.com/sign-up/">Sign up</a></li>
</ul></div></nav> -->

						<nav id="site-navigation" class="main-navigation" role="navigation">
            <button class="menu-toggle">Menu</button>
            <div class="menu-header-container"><ul id="menu-header-1" class="nav-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2105"><a href="https://caylent.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2290"><a href="https://caylent.com/pricing/">Pricing</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-1982"><a href="https://caylent.com/blog/">Blog</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2573"><a href="#">Solutions</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2554"><a href="https://caylent.com/devops-as-a-service/">DevOps as a Service</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2574"><a href="https://caylent.com/container-management-software/">Container Software</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2552"><a href="#">More Tools</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2565"><a href="https://caylent.com/devops-maturity-assessment/">DevOps Assessment</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1981"><a href="http://help.caylent.com">Support</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1980"><a href="https://docs.caylent.com/">Docs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2304"><a href="https://caylent.com/category/resources/">Resources</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2555"><a href="https://caylent.com/app-store/">App Store</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1983"><a href="https://app.caylent.com/login">Log in</a></li>
<li class="btn menu-item menu-item-type-post_type menu-item-object-page menu-item-2291"><a href="https://caylent.com/sign-up/">Sign up</a></li>
</ul></div></nav>
					</div><!-- .grid-full -->
				</div><!-- .row -->
			</div><!-- .container -->
		</header><!-- .header -->

	<section class="container">
		<div class="row">
			<div class="grid-full">

				<!-- Open the loop -->
				
					<article class="post-2733 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-resources category-sre category-sre-resources category-thought-leadership-resources tag-devops tag-devops-engineer tag-google tag-site-reliability-engineer tag-site-reliability-engineering tag-sre" id="post-2733">
						<header>
							<div class="meta"><time datetime="2018-06-30T08:49:01+00:00" pubdate>June 28th, 2018</time></div>

							<h1 id="post-2733" class="entry_title">SRE vs. DevOps: Any Common Ground?</h1>

							<div class="author">
								<img alt='' src='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <em>Written by Stefan Thorpe</em>
							</div><!-- .author -->

							<img width="1024" height="617" src="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png?fit=1024%2C617&amp;ssl=1" class="attachment-large size-large wp-post-image" alt="#SRE vs. #DevOps: Any Common Ground?" srcset="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png?w=1197&amp;ssl=1 1197w, https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png?resize=300%2C181&amp;ssl=1 300w, https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png?resize=768%2C463&amp;ssl=1 768w, https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png?resize=1024%2C617&amp;ssl=1 1024w" sizes="(max-width: 1024px) 100vw, 1024px" data-attachment-id="2734" data-permalink="https://caylent.com/sre-vs-devops/featured-image-sre-vs-devops/" data-orig-file="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png?fit=1197%2C721&amp;ssl=1" data-orig-size="1197,721" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SRE vs. DevOps: Any Common Ground?" data-image-description="" data-medium-file="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png?fit=300%2C181&amp;ssl=1" data-large-file="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-SRE-vs-DevOps.png?fit=1024%2C617&amp;ssl=1" />						</header>

						<div class="entry">

							<p>Software engineers spend significant amounts of time seeking to streamline software development and production. This endeavor results in constant changes that can cause software and performance defects which continue to consume even more time and productivity.</p>
<p>This imbalance has created the necessity for constant care and maintenance of the development pipeline. And teams turn to many methodologies to seek the answer for monitoring and maintaining the endless software application tasks that occur.</p>
<p>Over the years the two methodologies IT teams are turning to the most to improve performance and quality are DevOps and Site Reliability Engineering. So, how do the two compare on paper for the best outcome?</p>
<h2>What Is Site Reliability Engineering?</h2>
<p>Site Reliability Engineering (SRE) is a process engagement that commissions software developers to own the continuous daily operation of their applications in development. It is what happens when a software engineer is requested to design an operations team.</p>
<h3>History of SRE</h3>
<p>The SRE concept began in 2003 and was a Google initiative. Google was experiencing growing pains in their attempts to scale to the company that we know them to be today. One of the most contentious challenges the business faced was to support large-scale systems and also keep the development of new features going consistently.</p>
<p>To attain their goal, Google developed a new type of software engineering team with dual purposes. The team’s target was to support the introduction of new features while maintaining Google systems. SRE was the initiative that allowed the company to fulfill this goal and its advanced significantly outside of Google too. SRE teams are constructed with two main categories in mind:</p>
<ol>
<li>Hiring software engineers “who know enough about programming languages, data structures and algorithms, and performance to be able to write software that is effective.”</li>
<li>Building a team which consists of a “50-50 mix of people who have more of a software background and people who have more of a systems engineering background.” From <a href="https://landing.google.com/sre/interview/ben-treynor.html" target="_blank" rel="noopener">an interview on SRE with Ben Treynor, VP of Engineering</a>.</li>
</ol>
<p>SRE endeavors to bridge the gap between the operations team and development team. Where the development team may focus on fast production, the operations team may focus on measures to prevent production blowing-up. SRE comes in to harmonize the two different views.</p>
<h3>Pros and Cons of SRE</h3>
<h4>Pros of SRE</h4>
<ol>
<li>SRE bases product creation on the environmental conditions imposed by the customer. This aspect helps to optimize production costs as well as customer satisfaction.</li>
<li>Utilizing availability and reliability concepts helps to minimize failures and reduce time wastage. Unanticipated shortcomings usually cost customers their time, and the organization spends resources to resolve these failures.</li>
<li>SRE seeks to maximize throughput and minimize operating expenses. It works towards eliminating downtime through deploying predictive and preventive maintenance programs.</li>
<li>Use of SRE techniques helps minimize the time and resources impact of trying to eliminate early feature failures.</li>
<li>Reduced failures translate into fewer spare parts, minimized distribution system costs, service labor costs and storage cost for spare parts.</li>
</ol>
<h4>Cons of SRE</h4>
<ol>
<li>It is not easy to find suitable site reliability engineers as the hiring bar is set so high regarding coding and system engineering skills.</li>
<li>Since SRE is a new and unique discipline, there is limited industrial information on how to build and manage an SRE team.</li>
<li>It requires strong management support to direct the team away from their usual practices and adopt full, unorthodox SRE approaches.</li>
</ol>
<h2>What Is DevOps?</h2>
<p>It is a cultural framework in which the value of collaboration between the development and operations staff is embraced throughout a product or service development lifecycle. It is a methodology that changes people’s perspectives on work and values the diversity of skills within a team.</p>
<p>DevOps encourages the implementation of intentional processes that speed up the rate at which a business gain returns. It measures the effect of technical adjustments as well as social and cultural changes in the work environment.</p>
<h3>Pros and Cons of DevOps</h3>
<h4>Pros of DevOps</h4>
<ol>
<li>DevOps primary goal is to drive topline benefits around enhanced experiences and revenue opportunities. The methodology seeks to improve the cultural environment and flow of work in the technology value stream with the output of upgrading product/feature quality and customer satisfaction/end-user experience.</li>
<li>DevOps breaks down the silos that hierarchical organizational models create by eroding the barriers between development, operations, and testing teams.</li>
<li>The practices align business goals with information technology. Every effort initiated is formulated to shorten feedback loops, achieve continuous improvement, and deliver according to customers’ needs.</li>
<li>DevOps enables and speeds up business performance. IT teams are transformed and encouraged to deliver innovation which helps achieve business outcomes.</li>
<li>DevOps has brought about digital transformation. It embraces technological innovations that enhance customer experience and employee’s productivity.</li>
</ol>
<h4>Cons of DevOps</h4>
<ol>
<li>DevOps is not a smooth implementation for new teams to adopt. Beginning a DevOps transformation introduces new challenges to an organization and may be unfit for a particular work environment.</li>
<li>The benefits of DevOps are realized over a long period of time and change. Hence, the process requires patience.</li>
<li>DevOps associates with profound cultural changes. It can be difficult for people to drastically change the new normal and resistance is often encountered.</li>
</ol>
<h2>What Is the Difference Between a Site Reliability Engineer and a DevOps Engineer?</h2>
<ul>
<li>A site reliability engineer is accountable for monitoring applications or services after deployment to establish where automation is necessary to enhance a system’s health and availability. She or he assumes the role after the design work of a software developer.</li>
<li>On the other hand, a DevOps engineer is responsible for executing the development automation vision from the very beginning. The DevOps engineer’s role is visible from project start to fruition.</li>
</ul>
<p>The DevOps and SRE share common ground in the development process. The DevOps engineer takes a top position to craft culture and a system that automates tasks delivery in the development process. SRE serves as a compliment to DevOps as it embodies the philosophies of DevOps. It accomplishes DevOps by measuring and achieving reliability in a more prescribed manner.</p>
<p>DevOps reduces the gap between software development and software operations. Through engineering, SRE prescribes how to succeed in the various DevOps practices. Both of these disciplines fulfill a similar set of goals and include eliminating team barriers to deliver a better product. The two share a common ground in their complementary organizational goals and can work in accordance with each other.</p>
<p>For more on DevOps, don&#8217;t forget to check out the start of our<a href="https://caylent.com/devops-handbook-introduction-summary/" target="_blank" rel="noopener"> DevOps Handbook Synopsis</a>!</p>
<hr />
<p><a href="http://www.caylent.com/" target="_blank" rel="noopener">Caylent</a> offers DevOps-as-a-Service to high growth companies looking for help with microservices, containers, cloud infrastructure, and CI/CD deployments. Our managed and consulting services are a more cost-effective option than hiring in-house and we scale as your team and company grow. Check out some of the use cases and learn how we work with clients by visiting our <a href="https://caylent.com/devops-as-a-service/" target="_blank" rel="noopener">DevOps-as-a-Service offering</a>.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-2733" class="share-twitter sd-button share-icon no-text" href="https://caylent.com/sre-vs-devops/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-2733" class="share-facebook sd-button share-icon no-text" href="https://caylent.com/sre-vs-devops/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://caylent.com/sre-vs-devops/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-2733" class="share-linkedin sd-button share-icon no-text" href="https://caylent.com/sre-vs-devops/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-136943392-2733-5b3743fddae9c' data-src='https://widgets.wp.com/likes/#blog_id=136943392&amp;post_id=2733&amp;origin=caylent.com&amp;obj_id=136943392-2733-5b3743fddae9c' data-name='like-post-frame-136943392-2733-5b3743fddae9c'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Schedule a Demo - Inline --><div id="om-sj8vfjdk557n1muyy2ct-holder"></div><script>var sj8vfjdk557n1muyy2ct,sj8vfjdk557n1muyy2ct_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){sj8vfjdk557n1muyy2ct_poll(function(){if(window['om_loaded']){if(!sj8vfjdk557n1muyy2ct){sj8vfjdk557n1muyy2ct=new OptinMonsterApp();return sj8vfjdk557n1muyy2ct.init({"u":"38164.737675","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.optmstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;sj8vfjdk557n1muyy2ct=new OptinMonsterApp();sj8vfjdk557n1muyy2ct.init({"u":"38164.737675","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster -->
						</div><!-- .entry -->
					</article><!-- .the_post -->

				<!-- Close the loop -->
				
			</div><!-- .grid-full -->
		</div><!-- .row -->
	</section><!-- .content -->

	<section class="container">
		<div class="row">
			<div class="grid-full">
				<h3 class="title">Related Posts<h3>
				
							<article class="excerpt article-thumbnail">
								<header>
									<a href="https://caylent.com/brief-history-of-open-source/" class="post-thumbnail-container"><img width="1024" height="614" src="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Brief-history.png?fit=1024%2C614&amp;ssl=1" class="post-thumbnail wp-post-image" alt="Brief history of #opensource" srcset="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Brief-history.png?w=1200&amp;ssl=1 1200w, https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Brief-history.png?resize=300%2C180&amp;ssl=1 300w, https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Brief-history.png?resize=768%2C461&amp;ssl=1 768w, https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Brief-history.png?resize=1024%2C614&amp;ssl=1 1024w" sizes="(max-width: 1024px) 100vw, 1024px" data-attachment-id="2729" data-permalink="https://caylent.com/brief-history-of-open-source/featured-image-brief-history/" data-orig-file="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Brief-history.png?fit=1200%2C720&amp;ssl=1" data-orig-size="1200,720" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Featured image &#8211; Brief history of open source" data-image-description="" data-medium-file="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Brief-history.png?fit=300%2C180&amp;ssl=1" data-large-file="https://i0.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Brief-history.png?fit=1024%2C614&amp;ssl=1" /></a>

									<h2 id="post-2728" class="entry_title"><a href="https://caylent.com/brief-history-of-open-source/">A Brief History of Open Source</a></h2>
								</header>

								<div class="entry">
									<div class="author">
										<img alt='' src='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />										<em>Written by Stefan Thorpe</em>
									</div><!-- .author -->
								</div><!-- .entry -->
							</article><!-- .excerpt -->

				
							<article class="excerpt article-thumbnail">
								<header>
									<a href="https://caylent.com/7-ways-tune-standup-meetings/" class="post-thumbnail-container"><img width="1024" height="614" src="https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Tune-standups.png?fit=1024%2C614&amp;ssl=1" class="post-thumbnail wp-post-image" alt="Ways to tune your #standupmeetings" srcset="https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Tune-standups.png?w=1200&amp;ssl=1 1200w, https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Tune-standups.png?resize=300%2C180&amp;ssl=1 300w, https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Tune-standups.png?resize=768%2C461&amp;ssl=1 768w, https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Tune-standups.png?resize=1024%2C614&amp;ssl=1 1024w" sizes="(max-width: 1024px) 100vw, 1024px" data-attachment-id="2731" data-permalink="https://caylent.com/7-ways-tune-standup-meetings/featured-image-tune-standups/" data-orig-file="https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Tune-standups.png?fit=1200%2C720&amp;ssl=1" data-orig-size="1200,720" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ways to tune your #standups" data-image-description="" data-medium-file="https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Tune-standups.png?fit=300%2C180&amp;ssl=1" data-large-file="https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Tune-standups.png?fit=1024%2C614&amp;ssl=1" /></a>

									<h2 id="post-2730" class="entry_title"><a href="https://caylent.com/7-ways-tune-standup-meetings/">7 Ways to Tune Your Standup Meetings</a></h2>
								</header>

								<div class="entry">
									<div class="author">
										<img alt='' src='https://secure.gravatar.com/avatar/4d9790ac54ebf9a801b4b5167e76f840?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/4d9790ac54ebf9a801b4b5167e76f840?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />										<em>Written by JP La Torre</em>
									</div><!-- .author -->
								</div><!-- .entry -->
							</article><!-- .excerpt -->

				
							<article class="excerpt article-thumbnail">
								<header>
									<a href="https://caylent.com/kubernetes-managed-service/" class="post-thumbnail-container"><img width="1024" height="615" src="https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Kubernetes-MS-1.png?fit=1024%2C615&amp;ssl=1" class="post-thumbnail wp-post-image" alt="A #KubernetesManagedService Comparison — #AWS vs. #GKE vs. #AKS" srcset="https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Kubernetes-MS-1.png?w=1200&amp;ssl=1 1200w, https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Kubernetes-MS-1.png?resize=300%2C180&amp;ssl=1 300w, https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Kubernetes-MS-1.png?resize=768%2C461&amp;ssl=1 768w, https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Kubernetes-MS-1.png?resize=1024%2C615&amp;ssl=1 1024w" sizes="(max-width: 1024px) 100vw, 1024px" data-attachment-id="2726" data-permalink="https://caylent.com/kubernetes-managed-service/featured-image-kubernetes-ms-2/" data-orig-file="https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Kubernetes-MS-1.png?fit=1200%2C721&amp;ssl=1" data-orig-size="1200,721" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="A Kubernetes Managed Service Comparison — AWS vs. GKE vs. AKS" data-image-description="" data-medium-file="https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Kubernetes-MS-1.png?fit=300%2C180&amp;ssl=1" data-large-file="https://i1.wp.com/caylent.com/wp-content/uploads/2018/06/Featured-image-Kubernetes-MS-1.png?fit=1024%2C615&amp;ssl=1" /></a>

									<h2 id="post-2723" class="entry_title"><a href="https://caylent.com/kubernetes-managed-service/">The Heavyweight Championship: A Kubernetes Managed Service Comparison — EKS vs. GKE vs. AKS</a></h2>
								</header>

								<div class="entry">
									<div class="author">
										<img alt='' src='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d41e69c17d24335e3f8af6e8b16a9f57?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />										<em>Written by Stefan Thorpe</em>
									</div><!-- .author -->
								</div><!-- .entry -->
							</article><!-- .excerpt -->

				
			</div><!-- .grid-full -->
		</div><!-- .row -->
	</section><!-- .container -->

	<section class="callout">
		<div class="container">
			<div class="row">
				<div class="grid-full">
					<div class="heading">
						<h2 class="headline">The DevOps container management platform</h2>

						<ul class="cloud_providers">
							<li class="aws">Amazon AWS</li><!-- .aws -->
							<li class="azure">Microsoft Azure</li><!-- .azure -->
							<li class="google_cloud">Google Cloud</li><!-- .google_cloud -->
							<li class="digital_ocean">Digital Ocean</li><!-- .digital_ocean -->
						</ul><!-- .cloud_providers -->

						<h3 class="sub-headline">Unlimited users. Unlimited applications. Unlimited stacks. Easily manage Docker containers across any cloud.</h3>

						<a class="button primary" href="/sign-up/">Get Started—Free!</a>
					</div><!-- .heading -->
				</div><!-- .grid-full -->
			</div><!-- .row -->
		</div><!-- .container -->
	</section><!-- .callout -->


			<div class="container center-align-text standard-top-padding">
  <div class="row">
    <div class="grid-full">
      <div class="social-media-icons">
                      <a href="https://www.communityinviter.com/apps/caylenthq/caylent-hq" target="_blank" class="social-media-icon">
                <img src="https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/img/icons/social_media_icons/slack_icon.svg"/>
              </a>
                      <a href="https://www.linkedin.com/company/caylent/" target="_blank" class="social-media-icon">
                <img src="https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/img/icons/social_media_icons/linkedin.svg"/>
              </a>
                      <a href="https://www.twitter.com/caylentinc" target="_blank" class="social-media-icon">
                <img src="https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/img/icons/social_media_icons/twitter.svg"/>
              </a>
                      <a href="https://www.facebook.com/caylent/" target="_blank" class="social-media-icon">
                <img src="https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/img/icons/social_media_icons/facebook.svg"/>
              </a>
                      <a href="https://www.instagram.com/caylentinc/" target="_blank" class="social-media-icon">
                <img src="https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/img/icons/social_media_icons/instagram.svg"/>
              </a>
                      <a href="https://www.github.com/caylent" target="_blank" class="social-media-icon">
                <img src="https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/img/icons/social_media_icons/github.svg"/>
              </a>
              </div>
    </div><!-- .grid-full -->
  </div><!-- .row -->
</div><!-- .container -->
	
	<footer id="footer" class="footer">
		<div class="container">
			<div class="row">
				<div class="grid-full">
					<!--
					<div class="social"><a href="https://twitter.com/caylentinc">Twitter</a> <a href="https://slackin-caylent.now.sh/">Slack</a> <a href="https://github.com/caylent/">GitHub</a></div>
				 	-->

					<nav id="footer-nav" role="navigation"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-1986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1986"><a href="https://caylent.com/">Home</a></li>
<li id="menu-item-1987" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1987"><a href="https://docs.caylent.com/">Docs</a></li>
<li id="menu-item-1988" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1988"><a href="http://help.caylent.com">Support</a></li>
<li id="menu-item-2103" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2103"><a href="https://caylent.com/about/">About</a></li>
<li id="menu-item-1985" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-1985"><a href="https://caylent.com/blog/">Blog</a></li>
<li id="menu-item-2107" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2107"><a href="https://app.caylent.com/login">Log In</a></li>
<li id="menu-item-2321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2321"><a href="https://caylent.com/sign-up/">Sign Up</a></li>
</ul></div></nav>

					<p class="copy">&copy; 2018 Caylent, Inc. <span>|</span> <a href="https://caylent.com/terms-of-service/">Terms of Service</a> <span>|</span> <a href="https://caylent.com/privacy-policy/">Privacy Policy</a></p><!-- .copy -->
				</div><!-- .grid-full -->
			</div><!-- .row -->
		</div><!-- .container -->
	</footer><!-- .footer -->

	<a href="#0" class="top">Top</a>

	 <script type="text/javascript">
  analytics.track("Viewed Post", {"title":"SRE vs. DevOps: Any Common Ground?","category":"DevOps, Resources, SRE, SRE, Thought Leadership","noninteraction":true}, {"library":"analytics-wordpress"});
    
</script>
<script data-cfasync="false">
  document.onreadystatechange = function () {
    if (document.readyState == "complete") {
      var logout_link = document.querySelectorAll('a[href*="wp-login.php?action=logout"]');
      if (logout_link) {
        for(var i=0; i < logout_link.length; i++) {
          logout_link[i].addEventListener( "click", function() {
            Intercom('shutdown');
          });
        }
      }
    }
  };
</script>
<script data-cfasync="false">
  window.intercomSettings = {"app_id":"lsweki3y"};
</script>
<script data-cfasync="false">(function(){var w=window;var ic=w.Intercom;if(typeof ic==="function"){ic('reattach_activator');ic('update',intercomSettings);}else{var d=document;var i=function(){i.c(arguments)};i.q=[];i.c=function(args){i.q.push(args)};w.Intercom=i;function l(){var s=d.createElement('script');s.type='text/javascript';s.async=true;s.src='https://widget.intercom.io/widget/lsweki3y';var x=d.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);}if(w.attachEvent){w.attachEvent('onload',l);}else{w.addEventListener('load',l,false);}}})()</script>	<div style="display:none">
	<div class="grofile-hash-map-d41e69c17d24335e3f8af6e8b16a9f57">
	</div>
	<div class="grofile-hash-map-4d9790ac54ebf9a801b4b5167e76f840">
	</div>
	</div>
<!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Lightup post Schedule Demo --><div id="om-xatekwfbfvmkefwzzq2h-holder"></div><script>var xatekwfbfvmkefwzzq2h,xatekwfbfvmkefwzzq2h_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){xatekwfbfvmkefwzzq2h_poll(function(){if(window['om_loaded']){if(!xatekwfbfvmkefwzzq2h){xatekwfbfvmkefwzzq2h=new OptinMonsterApp();return xatekwfbfvmkefwzzq2h.init({"u":"38164.748594","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.optmstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;xatekwfbfvmkefwzzq2h=new OptinMonsterApp();xatekwfbfvmkefwzzq2h.init({"u":"38164.748594","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster -->
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/caylent.com\/sre-vs-devops\/":2733};
	</script>
		<script type="text/javascript">var sj8vfjdk557n1muyy2ct_shortcode = true;var xatekwfbfvmkefwzzq2h_shortcode = true;</script>
		<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/caylent.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9.1'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201826'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/themes/website/js/navigation.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/ajax-filter-search/core/js/script.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/postmessage.js?ver=5.4'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=5.4'></script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=5.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://2wded2jn6ekmzt6b3ruvnh15-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.4'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=20170629#ver=20170629' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-201826.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.4',blog:'136943392',post:'2733',tz:'-7',srv:'caylent.com'} ]);
	_stq.push([ 'clickTrackerInit', '136943392', '2733' ]);
</script>
		<script type="text/javascript">var omapi_localized = { ajax: 'https://caylent.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '212aea4684', slugs: {"sj8vfjdk557n1muyy2ct":{"slug":"sj8vfjdk557n1muyy2ct","mailpoet":false},"xatekwfbfvmkefwzzq2h":{"slug":"xatekwfbfvmkefwzzq2h","mailpoet":false}} };</script>
		
	</body>
</html>
